Getting started
.NET Application
GsaAPI.dll is a .NET Framework 4.8 library that enables user to run GSA headless.
The .NET API is not suitable for use in a multi-threaded application.
Steps to use the API .NET application is given below.
Steps to use GsaAPI.dll in .NET Application:
Install latest GSA 10.2 (for GsaAPI.dll)
Add GSA install path to System environment variable "Path" list (see the environment variable setup page)
The C# application that refers the GsaAPI.dll must be 64bit platform. As the API dll is 64bit, it cannot be used in AnyCPU/32bit platforms
Python
Steps to use the API in Python application is given below.
Steps to use GsaAPI.dll in python:
Install pythonnet 2.4.0 (pip install pythonnet==2.4.0) https://pypi.org/project/pythonnet/2.4.0/. Make sure that >>> import clr works in python.
Install latest GSA 10.2 (for GsaAPI.dll)
Add Gsa install path to System environment variable "Path" list (see the environment variable setup page)